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Executive Summary 

This document provides the technical documentation and user manual for the joint Pattern 
Specification (A6.D2.1) and Pattern Management (A6.D2.2) Tools. This document is accompanied 
by the source code of the tools and an installer. This document provides information regarding the 
installation and usage of the tools along with technical details regarding its development. 
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1. User Manual 
The purpose of this section is to provide a user manual for the Pattern Specification and 
Management Tool and to present to the user the functionality of the application and a short 
description of its functions and its installation process. 

1.1. Installation  
1.1.1. Pre-requisites  
This application has the following requirements: 

For the clients: 

¾  Microsoft Windows ® 2000 or later 

¾  .NET runtime version 2.0 

¾  23MB of free disk space for the application and also additional free disk space for the .NET 
2.0 Framework. 

For the server: 

¾  Microsoft Windows ® 2000 or later 

¾  .NET runtime version 2.0 

¾  MySQL5.1b Database Server 

¾  IIS Server that runs ASP.NET 2.0 

¾  25MB of free disk space for the application and also additional free disk space for the .NET 
2.0 Framework. 

1.1.2. Installation of the server 

¾  Install MySQL5.1b and run the proper scripts. 

¾  Install .NET runtime version 2.0 if required 

¾  In IIS create a new virtual directory under the “Default Web Site” and copy the contents of 
“SerenityService” folder in this directory. 

¾  Edit the contents of the file “Web.config” that exists in the directory you created in IIS. In 
particular, you have to specify the correct connection string for the MySQL Database in this 
file. It is necessary to change the value of the attribute “connectionString” of the <add> tag 
that is under the <connectionStrings> tag. 

  For example , the <connectionStrings> tag should have the following contents: 

<connectionStrings> 

    <add name="MySQLDB" 
connectionString="server=serenity_server;uid=root;pwd=;database=serenity"></add> 

    </connectionStrings> 
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1.1.3. Installation of the clients 

¾  Install .NET runtime version 2.0 if required 

¾  Run the “SERENITY PSMT.exe” installer 

¾  Run .\bin\SerenityXMLEditor.exe or the PSMT icon created in the start list by the instalelr 

¾  In the login screen that will show up press the “Configuration” button 

 

Figure 1 – Login Screen 

¾  In the “Configuration” screen it is necessary to specify the location of the XSD schema files 
for the patterns,implementations and classes. These XSD schema files will be used when the 
user is creating a class,pattern or implementation xml file in the local filesystem (not from 
the database). They can be found in the subfolder XSD of the directory where you unzipped 
the files. 

¾  Also in the “Configuration” screen the user has to specify the url of the Serenity XML 
Editor Webservice. 
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Figure 2 – Configuration Screen 

 

1.2. Overview of the application  
1.2.1. Application main screen  
After the login process the main application screen is being shown. 

 

Figure 3 – Configuration Screen 

Application Main Screen 

This is the screen where the user writes the documents and does most of the functions. It consists 
from the text editor box in the middle of the screen. This is where the user edits the xml document. 
It provides code completion based on the schema file for tags, attributes and values of attributes. 
Also it provides syntax highlighting and folding of xml code.  

The structure of the xml document is being displayed on a treeview pad on the right of the text 
editor. In particular , the xml tag names , the attributes and the text of xml tags are being displayed 
as a treeview structure with different icons for xml tags , attributes and text and while moving the 
mouse over an attribute or text node the value of the attribute or text is being displayed as a tooltip. 
Changing the xml document from the editor automatically changes the treeview pad. By pressing a 
node of the treeview pad , automatically the corresponding xml tag in the document of the editor is 
being selected and the caret of the editor is being moved to its position within the document. 

With right click on a node of the treeview pad, a menu is being shown where the user can add child 
nodes for this node (based on the schema file and node itself) and also he can add attributes (based 
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on the schema and the node). Moreover he can add text for this node or edit the text of this node (in 
a separate form) .In addition, it is possible to select to remove the node. 

With right click on the root node of the treeview pad a menu is being shown where the user can add 
new nodes based on the type of the document and its schema (i.e. class, pattern, implementation 
etc.) 

The user is also possible to drap and drop nodes of the treeview pad and the xml document is also 
being changed automatically. 

The user is possible on the treeview pad to move the nodes up and down and the document of the 
editor is also being changed automatically. Also it is possible to move the nodes left (i.e. move the 
node to the previous level) or to move the nodes right (i.e. move the node to the next level) and the 
document is changing also automatically. 

When selecting Add Node/Edit Node/Add Attribute/Edit Attribute for a specific node the user is 
being presented a new screen which displays the type of the node that is going to be added (or is 
being currently edited) and also comments/documentation that is related to this node based on the 
schema of the document. Moreover, for numerical node types the screen the user is being presented 
a different screen where it is only possible to enter numerical values. Also validation is being made 
based on the schema type of the node. For example if the type of the node is positiveInteger he will 
be able only to insert positive integers , unsignedShort only unsigned short values etc. .Moreover 
for Boolean schema types a new screen is being shown with two radio buttons (true/false). For all 
other possible types the screen contains a textbox where the user is possible to insert the value. 

 

Figure 4 – Add attribute screen (element type “String”) 
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Figure 5 – Add attribute screen (element type “Boolean”) 

In addition the user can refresh of the treeview structure of the xml document by pressing the 
refresh button that is above the treeview. 

Also, on the lower side of the application’s main screen is the validation errors panel. When the 
user chooses to validate the document this is where the errors of the validation are being displayed. 
By pressing on an error, the document is being scrolled to the position where the error is. 

On the upper side of the screen is the main menu through which the user can access the various 
functionality of the application. Moreover, there is the toolbar which enables functions such as 
set/unset bookmark for current line, go to next/previous bookmark, search the documents, comment 
or uncomment code and also basic functionality such as create a new document, open a document 
and also save the document. 

It is possible to edit multiple documents at the same time. Above the text editor is the active 
document selector tab panel where the user can select which one of the open documents wants to 
edit. 

At any time, the user can see the properties of the active document by selecting the properties pad. 
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Figure 6 – Document’s property pad 

1.2.2. Creating a new document 
In order to create a new document the user select File->New->File from the main menu. 

Then the below screen is being shown. The user can select there the type of the document he wants 
to create. It is possible to create a class, pattern, implementation or xsd document that will be based 
on a schema of the local file system (it will be based on the schema file that has been specified in 
the “Configuration” screen). Moreover, it is possible to create a new document that will be based on 
a schema of the database. 
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Figure 7 – Create new document screen 

By pressing the create button the new document is being created. 

1.2.3. Creating and saving a new document to the database 
In case the user wants to create document that is based on a schema of the database and then save it 
to the database he has to do the following. At first, choose File->New->File from the main menu. 
Then, choose create “document based on database xsd” in the screen that will be shown and 
afterwards he has to choose the type of the document.  

When the user has finished editing the document he has to choose File->Save To Database As from 
the main menu. Then a new screen will be shown where the user has to enter the uri of the 
document. This uri has to be unique and should identify the document. The parent of the document 
will be automatically extracted from the document’s reference tag and will be stored in the 
database. 

 

Figure 8 – Save document to database screen 

1.2.4. Searching the database for xml documents and opening them 
The user can search the database for xml documents and open them by selecting “Search->Search 
Database for XML Files” from the main menu. The database can be searched for class, pattern, and 
implementation documents with many criteria including uri, name , text  within the document , 
created by , updated by and also the user is able to search for pattern documents that are related to a 
specific class document and implementation documents that are related to a specific pattern 
document. 

Moreover, it is possible to search for documents that have specific properties. The user can select 
more than one search criteria related to properties and can also define various search operations 
such as “Equal”,”Not Equal”,”Starts with”,”Ends With”,”Like” for these properties. In addition, 
power users can directly query the database for documents by entering the “Where Clause” of the 
search in the appropriate tab. 

After selecting a document from the search results the user is enabled to delete it, if he has the 
proper user access permissions and also open it. 
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Figure 9 – XML Documents Search Screen 

 

 

Figure 10 – XML Documents Search Screen – Document Properties 
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Figure 11 – XML Documents Search Screen – Where Clause 

1.2.5. Searching the database for xsd (schema) documents and opening them 
As in the previous screen the user can search the database for xsd (schema) documents and open 
them by selecting “Search->Search Database for XSD Files” from the main menu.  

 

Figure 12 – Schema Documents Search Screen 

Moreover the user can delete or open the schema document that has been selected. 

1.2.6. Adding the document’s reference 
A pattern document has a reference to a class document and also an implementation document has a 
reference to a pattern document. In order to add this reference, right click on the reference node of 
the document tree (the S_and_DclassReference and S_and_DPatternReference nodes). Then in the 
context menu that will be shown select 
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“Add Reference”. Afterwards, a search screen will be shown where it is possible to search for 
classes or patterns accordingly and add a new reference for the document. 

1.2.7. Validating the document against the schema 
By selecting Tools->Validate XML from the main menu the user can validate the xml document 
based on the schema and display the validation errors on the validation errors pad. By pressing on 
an error the user is moved to its line within the code. Also, before saving a document to the 
database the document is being validated automatically and only if the validation succeeded it will 
be saved. 

1.2.8. Document relations management 

 

Figure 13 – Document relations management screen 

It is possible to manage the relations (references) of documents of the database easily and quickly. 
By selecting Tools->Document relations management from the main menu a new screen will be 
shown. There on the left of the screen is a tree that represents how the documents are related to each 
other. On the first level are the class documents and in the second level the pattern documents and 
in the third level the implementation documents. The user can drag and drop a document node to 
another document node.  This means he can change the references of assigned documents and also 
assign a new reference for those who do not have one.  

1.2.9. Managing users of the application and setting role permissions 
The application has a security policy. Each user has a unique user id and password and belongs to a 
specific role. Each role has different permissions for the various functions of the application. For 
example a role is able to insert new xml documents to the database but not able to delete them from 
the database etc. 

In order, to manage roles and their permissions, the administrator should select Tools->Serenity 
Roles from the main menu. 

There, it is possible to view the different roles, create a new role, delete an existing one and set its 
permissions. 
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Figure 14 – Roles administration screen 

In order, to manage users, the administrator should select Tools->Serenity Users from the main 
menu. There it is possible to view and edit the details of the users, create a new user or delete an 
existing one. 

 

Figure 15 – Users administration screen 
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2. Technical Documentation 

2.1. Scope of the section 
The scope of this section is to describe architecture of the Serenity Pattern Specification and 
Management Tool. Specifically, it describes the architecture, database schema, data dictionary , and 
also the methods that are provided through the tool. 

2.2. Architecture 
The architecture of the tol is the following. 

 

Figure 16 – Serenity XML Editor Architecture 

The user uses the Serenity XML Editor client, which contains the main functionality of the 
application. It is written in Microsoft .NET 2.0.  

For functions such as user authentication, access permissions, loading and saving classes, patterns 
or implementation documents to the database the Serenity XML Editor client communicates with 
Serenity Web Service. This is also written in Microsoft .NET 2.0. 

The Serenity Web Service is storing and retrieving information from a MySQL version 5.1.11 
database. 
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2.3. Entity Relationship Diagram of the Database 

 

Figure 17 – Relationship Diagram of Database 

2.4. Serenity Web Service API description 
The methods that are available through the Serenity Web Service are the following: 

¾  Insert XML document into the database 

¾  Update database XML document 

¾  Delete XML document from the database 

¾  Insert XSD document into the database 

¾  Update database XSD document 

¾  Delete XSD document from the database 

¾  Get database XSD document 

¾  Get all database XSD documents 

¾  Search for database XML documents 

¾  Search for database XSD documents 

¾  Get first record of Serenity XML Editor Users 

¾  Get next record of Serenity XML Editor Users 

¾  Get previous record of Serenity XML Editor Users 
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¾  Get last record of Serenity XML Editor Users 

¾  Insert record of Serenity XML Editor Users 

¾  Update record of Serenity XML Editor Users 

¾  Delete record of Serenity XML Editor Users 

¾  Get first record of Serenity XML Editor Roles 

¾  Get next record of Serenity XML Editor Roles 

¾  Get previous record of Serenity XML Editor Roles 

¾  Get last record of Serenity XML Editor Roles 

¾  Insert record of Serenity XML Editor Roles 

¾  Update record of Serenity XML Editor Roles 

¾  Delete record of Serenity XML Editor Roles 

¾  Get permissions of Serenity XML Editor Role 

¾  Get empty permissions of Serenity XML Editor Role 

¾  Validate username and password of user 

2.4.1. Insert XML document into the database 
2.4.1.1 Description 

This function inserts a xml document into the database 

2.4.1.2 Function declaration 

public  bool  InsertXMLFileToDatabaseExtended( 

    string  username, 

    string  type, 

    int  xsd_id, 

    string  uri, 

    string  name, 

    string  doc, 

    int  session_id, 

    string  pattern_id, 

    string  class_id, 

    string [] properties); 

2.4.1.3 Function input parameters 

¾  Username 

¾  Type , Xml document type 

¾  Xsd_id , the id of the database xsd document on which the xml document is based 

¾  Uri , the uri of the xml document 
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¾  Name , the name of the xml document 

¾  Doc , the contents of the xml document 

¾  Session_id , the session id of the user 

¾  Pattern_id , the id of the pattern in the database which is related to this xml document 

¾  Class_id , the id of the class in the database which is related to this xml document 

¾  Properties , array consisting of the various properties of the xml document 

2.4.1.4 Function call example 

InsertXMLFileToDatabaseExtended(“user1»,»»,3,»atc.t est.pattern1”,”pattern1
”,”<xml>..</xml>”,15030,”3”,””,null); �

2.4.1.5 Function output 

The function returns true for success and false for failure. 

2.4.2. Update database XML document 
2.4.2.1 Description 

This function updates a xml document of the database 

2.4.2.2 Function declaration 

public  bool  UpdateXMLFileToDatabaseExtended( 

    int  sd_xml_id, 

    string  username, 

    int  xsd_id, 

    string  uri, 

    string  name, 

    string  doc, 

    int  session_id, 

    string  pattern_id, 

    string  class_id, 

    string [] properties); 

2.4.2.3 Function input parameters 

¾  Sd_xml_id , id of the database record that corresponds to this database xml document 

¾  Username 

¾  Xsd_id , the id of the database xsd document on which the xml document is based 

¾  Uri , the uri of the xml document 

¾  Name , the name of the xml document 

¾  Doc , the contents of the xml document 

¾  Session_id , the session id of the user 

¾  Pattern_id , the id of the pattern in the database which is related to this xml document 
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¾  Class_id , the id of the class in the database which is related to this xml document 

¾  Properties , array consisting of the various properties of the xml document 

2.4.2.4 Function call example 

UpdateXMLFileToDatabaseExtended 
(100,“user1»,3,»atc.test.pattern1”,”pattern1”,”<xml >..</xml>”,15030,”3”,””,null)
; �

2.4.2.5 Function output 

The function returns true for success and false for failure. 

2.4.3. Delete XML document from the database 
2.4.3.1 Description 

This function deletes a xml document from the database 

2.4.3.2 Function declaration 

public  bool  DeleteXMLFileFromDatabase( 

    int  sd_xml_id, 

    string  username, 

    int  session_id); 

2.4.3.3 Function input parameters 

¾  Sd_xml_id , id of the database record that corresponds to this database xml document 

¾  Username 

¾  Session_id , the session id of the user 

2.4.3.4 Function call example 

DeleteXMLFileFromDatabase (100,“user1»,15030); �

2.4.3.5 Function output 

The function returns true for success and false for failure. 

2.4.4. Insert XSD document into the database 
2.4.4.1 Description 

This function inserts a xsd document into the database 

2.4.4.2 Function declaration 

public  bool  InsertXSDFileToDatabase( 

    string  username,         

    string  uri, 

    string  name,     

    string  doc, 

    int  session_id); 

2.4.4.3 Function input parameters 

¾  Username 



 

A6.D2.1 & A6.D2.2 – Pattern Specification and 
Management Tools 

 

SERENITY - 027587 Version 1.0   Page 22 of 35 

 

¾  Uri , the uri of the xml document 

¾  Name , the name of the xsd document 

¾  Doc , the contents of the xsd document 

¾  Session_id , the session id of the user 

2.4.4.4 Function call example 

InsertXSDFileToDatabase 
(“user1»,»atc.test.pattern1”,”pattern1”,”<xml>..</x ml>”,15030); �

2.4.4.5 Function output 

The function returns true for success and false for failure. 

2.4.5. Update database XSD document 
2.4.5.1 Description 

This function updates a xsd document of the database 

2.4.5.2 Function declaration 

public  bool  UpdateXSDFileToDatabase(     

    string  username, 

    int  xsd_id, 

    string  uri,     

    string  name, 

    string  doc, 

    int  session_id); 

2.4.5.3 Function input parameters 

¾  Username 

¾  Xsd_id , record id of the xsd document  

¾  Uri , the uri of the xml document 

¾  Name , the name of the xsd document 

¾  Doc , the contents of the xsd document 

¾  Session_id , the session id of the user 

2.4.5.4 Function call example 

UpdateXSDFileToDatabase 
(“user1»,100,»atc.test.pattern1”,”pattern1”,”<xml>. .</xml>”,15030); �

2.4.5.5 Function output 

The function returns true for success and false for failure. 

2.4.6. Delete database XSD document 
2.4.6.1 Description 

This function deletes a xsd document from the database 
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2.4.6.2 Function declaration 

public  bool  DeleteXSDFileFromDatabase( 

    int  sd_xsd_id, 

    string  username, int  session_id); �

2.4.6.3 Function input parameters 

¾  Xsd_id , record id of the xsd document  

¾  Username 

¾  Session_id , the session id of the user 

2.4.6.4 Function call example 

DeleteXSDFileFromDatabase (100,“user1»,15030); �

2.4.6.5 Function output 

The function returns true for success and false for failure. 

2.4.7. Get database XSD document 
2.4.7.1 Description 

This function returns the contents of database xsd document. 

2.4.7.2 Function declaration 

public  string  GetDatabaseXSD( int  xsd_id); 

2.4.7.3 Function input parameters 

¾  Xsd_id , record id of the xsd document  

2.4.7.4 Function call example 

GetDatabaseXSD (100); �

2.4.7.5 Function output 

The function returns the contents of the xsd document as a string 

2.4.8. Get all database XSD documents 
2.4.8.1 Description 

This function returns the contents of database xsd document. 

2.4.8.2 Function declaration 

public  DataSet  GetAllDatabaseXSD(); 

2.4.8.3 Function input parameters 

None 

2.4.8.4 Function call example 

GetAllDatabaseXSD(); �

2.4.8.5 Function output 

The function returns a DataSet containing all the xsd documents from the database. 
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Specifically, the DataTable of the DataSet contains the following columns: 

¾  Sd_xsd , id of the xsd 

¾  Name , name of the xsd 

¾  Doc , contents of the xsd 

2.4.9.  Search for database XML documents 
2.4.9.1 Description 

This function searches the database for xml documents based on various search criteria 

2.4.9.2 Function declaration 

public  DataSet  SearchForXMLFilesExtended( 

    string  username, 

    int  type, 

    string  name, 

    string  uri, 

    string  class_reference, 

    string  pattern_reference, 

    string  ins_by, 

    string  upd_by, 

    string  doc, 

    string [] properties, 

    string [] properties_search_operations, 

    string  where_clause, 

    int  session_id 

        ); 

2.4.9.3 Function input parameters 

¾  Username 

¾  Type , record id of the xsd on which the xml document is based 

¾  Name , name of the xml document 

¾  Uri , uri of the xml document 

¾  Class_reference ,  class reference of the xml document 

¾  Pattern_reference , pattern reference of the xml document 

¾  Ins_by , inserted by 

¾  Upd_by , updated by, 

¾  Doc , parts of the contents of the xml document 

¾  Properties , properties of the xml document 
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¾  Properties_search_operations , search operations for the properties of the xml documents. 
Can be one of the following :  

EQUAL, NOT EQUAL, LIKE, STARTS WITH, ENDS WITH. 

¾  Where_clause , custom where clause for power users 

¾  Session_id , the session id of the user 

2.4.9.4 Function call example 

SearchForXMLFilesExtended( 

“user1”, 

3, 

“pattern”, 

“”, 

“”, 

“”, 

“user50”, 

“”, 

“”, 

“security”, 

“LIKE” 

 “xsd_id=50” 

10050); 

2.4.9.5 Function output 

The function returns a DataSet containing result of the search. 

2.4.10.  Search for database XSD documents 
2.4.10.1 Description 

This function searches the database for xsd documents based on various search criteria 

2.4.10.2 Function declaration 

public  DataSet  SearchForXSDFiles( 

    string  username,     

    string  name, 

    string  uri, 

    string  ins_by, 

    string  upd_by, 

    string  doc, 

    int  session_id 

        );  

2.4.10.3 Function input parameters 

¾  Username 
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¾  Name , name of the xsd document 

¾  Uri , uri of the xsd document 

¾  Ins_by , inserted by 

¾  Upd_by , updated by, 

¾  Doc , parts of the contents of the xml document 

¾  Session_id , the session id of the user 

2.4.10.4 Function call example 

SearchForXSDFiles ( 

“user1”, 

“pattern”, 

“”, 

“”, 

“”, 

“”, 

10050); 

2.4.10.5 Function output 

The function returns a DataSet containing result of the search. 

2.4.11.  Get first record of Serenity XML Editor Users 
2.4.11.1 Description 

This function returns the first record of the Serenity XML Editor Users table of the database 

2.4.11.2 Function declaration 

public  DataSet  UsersMoveFirst(); 

2.4.11.3 Function input parameters 

None 

2.4.11.4 Function call example 

UsersMoveFirst(); �

2.4.11.5 Function output 

The function returns a DataSet containing the first record of the database’s users table. 

2.4.12. Get next record of Serenity XML Editor Users 
2.4.12.1 Description 

This function returns the next record of the Serenity XML Editor Users table of the database 

2.4.12.2 Function declaration 

public  DataSet  UsersMoveNext( int  current_user_id);     

2.4.12.3 Function input parameters 

¾  Current_user_id , the current record id 
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2.4.12.4 Function call example 

UsersMoveNext (100); �

2.4.12.5 Function output 

The function returns a DataSet containing the next record of the database’s users table. 

2.4.13. Get previous record of Serenity XML Editor Users 
2.4.13.1 Description 

This function returns the previous record of the Serenity XML Editor Users table of the database 

2.4.13.2 Function declaration 

public  DataSet  UsersMovePrevious( int  current_user_id);  

2.4.13.3 Function input parameters 

¾  Current_user_id , the current record id 

2.4.13.4 Function call example 

UsersMovePrevious (100); �

2.4.13.5 Function output 

The function returns a DataSet containing the previous record of the database’s users table. 

2.4.14.  Get last record of Serenity XML Editor Users 
2.4.14.1 Description 

This function returns the last record of the Serenity XML Editor Users table of the database 

2.4.14.2 Function declaration 

public  DataSet  UsersMoveLast(); 

2.4.14.3 Function input parameters 

����  

2.4.14.4 Function call example 

UsersMoveLast(); �

2.4.14.5 Function output 

The function returns a DataSet containing the last record of the database’s users table. 

2.4.15.  Insert record of Serenity XML Editor Users 
2.4.15.1 Description 

This function inserts a Serenity XML Editor User record into the database. 

2.4.15.2 Function declaration 

public  bool  UsersInsert( 

    string  current_user, 

    string  username, 

    string  password, 

    int  role, 
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    string  first_name, 

    string  last_name, 

    string  phone, 

    string  email); 

2.4.15.3 Function input parameters 

¾  Current_user , username of the current user 

¾  Username 

¾  Password  

¾  Role , database record id of the role of the user 

¾  First_name , first name 

¾  Last_name , last name 

¾  Phone 

¾  Email 

2.4.15.4 Function call example 

UsersInsert ( 

“user1”, 

“user50”, 

“t@st1040”, 

12, 

“Peter”, 

“Schimauski”, 

�����	��
�
�
��

��
����������������� ���

2.4.15.5 Function output 

The function returns true for success and false for failure. 

2.4.16.  Update record of Serenity XML Editor Users 
2.4.16.1 Description 

This function updates a record of the  Serenity XML Editor Users. 

2.4.16.2 Function declaration 

public  bool  UsersUpdate( 

        int  user_id, 

        string  current_user, 

        string  username, 

        string  password, 

        int  role, 

        string  first_name, 
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        string  last_name, 

        string  phone, 

        string  email); 

2.4.16.3 Function input parameters 

¾  User_id , the record if of the user 

¾  Current_user , username of the current user 

¾  Username 

¾  Password  

¾  Role , database record id of the role of the user 

¾  First_name , first name 

¾  Last_name , last name 

¾  Phone 

¾  Email 

2.4.16.4 Function call example 

UsersUpdate ( 

100, 

“user1”, 

“user50”, 

“t@st1040”, 

12, 

“Peter”, 

“Schimauski”, 

�����	��
�
�
��

��
����������������� ���

2.4.16.5 Function output 

The function returns true for success and false for failure. 

2.4.17.  Delete record of Serenity XML Editor Users 
2.4.17.1 Description 

This function deletes a record of the Serenity XML Editor Users. 

2.4.17.2 Function declaration 

public  bool  UsersDelete( 

        int  user_id); 

2.4.17.3 Function input parameters 

¾  User_id , the record if of the user 
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2.4.17.4 Function call example 

UsersDelete (100); 

2.4.17.5 Function output 

The function returns true for success and false for failure. 

2.4.18.  Get first record of Serenity XML Editor Roles 
2.4.18.1 Description 

This function returns the first record of the Serenity XML Editor Roles table of the database 

2.4.18.2 Function declaration 

public  DataSet  RolesMoveFirst(); 

2.4.18.3 Function input parameters 

None 

2.4.18.4 Function call example 

RolesMoveFirst(); �

2.4.18.5 Function output 

The function returns a DataSet containing the first record of the database’s roles table. 

2.4.19. Get next record of Serenity XML Editor Roles 
2.4.19.1 Description 

This function returns the next record of the Serenity XML Editor Roles table of the database 

2.4.19.2 Function declaration 

public  DataSet  RolesMoveNext( int  current_role_id); 

2.4.19.3 Function input parameters 

¾  Current_role_id , the current record id 

2.4.19.4 Function call example 

RolesMoveNext (100); �

2.4.19.5 Function output 

The function returns a DataSet containing the next record of the database’s roles table. 

2.4.20. Get previous record of Serenity XML Editor Roles 
2.4.20.1 Description 

This function returns the previous record of the Serenity XML Editor Roles table of the database 

2.4.20.2 Function declaration 

public  DataSet  RolesMovePrevious( int  current_role_id); 

2.4.20.3 Function input parameters 

¾  Current_role_id , the current record id 
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2.4.20.4 Function call example 

RolesMovePrevious (100); �

2.4.20.5 Function output 

The function returns a DataSet containing the previous record of the database’s roles table. 

2.4.21.  Get last record of Serenity XML Editor Roles 
2.4.21.1 Description 

This function returns the last record of the Serenity XML Editor Roles table of the database 

2.4.21.2 Function declaration 

public  DataSet  RolesMoveLast(); 

2.4.21.3 Function input parameters 

None 

2.4.21.4 Function call example 

RolesMoveLast(); �

2.4.21.5 Function output 

The function returns a DataSet containing the last record of the database’s roles table. 

2.4.22.  Insert record of Serenity XML Editor Roles 
2.4.22.1 Description 

This function inserts a Serenity XML Editor Roles record into the database. 

2.4.22.2 Function declaration 

public  bool  RolesInsert( 

    string  current_user, 

    string  name, 

    int [] alpriv_ids, 

    string [] alpriv_isactive 

     ); 

2.4.22.3 Function input parameters 

¾  Current_user , username of the current user 

¾  Name ,  name of the role 

¾  Alpriv_ids , array containing the ids of the permissions 

¾  Alprin_isactive , array containing the is active value of the permissions (“y” for active , “n” 
for inactive). 

2.4.22.4 Function call example 

RolesInsert ( 

“user1”, 

“Admin” 
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[1,2,3,4,5], 

[“y”,”n”,”y”,”n”,”y”] 

); 

2.4.22.5 Function output 

The function returns true for success and false for failure. 

2.4.23.  Update record of Serenity XML Editor Roles 
2.4.23.1 Description 

This function updates a record of the  Serenity XML Editor Roles. 

2.4.23.2 Function declaration 

public  static  bool  RolesUpdate( 

        int  role_id,         

        string  current_user,         

        string  name, 

        int [] alpriv_ids, 

        string [] alpriv_isactive 

        ); 

2.4.23.3 Function input parameters 

¾  role_id , the record if of the role 

¾  Current_user , username of the current user 

¾  Name, name of the role 

¾  Role , database record id of the role of the user 

¾  Alpriv_ids , array containing the ids of the permissions 

¾  Alprin_isactive , array containing the is active value of the permissions (“y” for active , “n” 
for inactive). 

2.4.23.4 Function call example 

RolesUpdate ( 

100, 

“user1”, 

“Admin” 

[1,2,3,4,5], 

[“y”,”n”,”y”,”n”,”y”]); 

2.4.23.5 Function output 

The function returns true for success and false for failure. 

2.4.24.  Delete record of Serenity XML Editor Roles 
2.4.24.1 Description 

This function deletes a record of the Serenity XML Editor Roles. 
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2.4.24.2 Function declaration 

    public  bool  RolesDelete( 

        int  role_id); 

2.4.24.3 Function input parameters 

¾  Role_id , the record if of the role 

2.4.24.4 Function call example 

RolesDelete (100); 

2.4.24.5 Function output 

The function returns true for success and false for failure. 

2.4.25. Get permissions of Serenity XML Editor Role 
2.4.25.1 Description 

This function returns the permissions of a Serenity XML Editor Role 

2.4.25.2 Function declaration 

public  DataSet  RolesGetPermissions( int  current_role_id); 

2.4.25.3 Function input parameters 

¾  Current_role_id , the record id of the role 

2.4.25.4 Function call example 

RolesGetPermissions(100); �

2.4.25.5 Function output 

The function returns a DataSet containing the permissions information related to the role. 

2.4.26. Get empty permissions of Serenity XML Editor Role 
2.4.26.1 Description 

This function returns uninitialized permissions of Serenity XML Editor Roles 

2.4.26.2 Function declaration 

public  DataSet  RolesGetEmptyPermissions(); 

2.4.26.3 Function input parameters 

None 

2.4.26.4 Function call example 

RolesGetEmptyPermissions(); �

2.4.26.5 Function output 

The function returns a DataSet containing the permissions information. 

2.4.27. Validate username and password of user 
2.4.27.1 Description 

This function validates the username and password of a user 
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2.4.27.2 Function declaration 

public  int  SecurityValidateUser( string  username, string  password);  

2.4.27.3 Function input parameters 

¾  Username 

¾  password 

2.4.27.4 Function call example 

SecurityValidateUser(“user1”,”p$tt#rn”); �

2.4.27.5 Function output 

The function returns a unique session id for the user. The user should call this function as first in 
order to get a new session id and afterwards should use this session id in all the following calls of 
other functions. 

In case of invalid credentials an exception is being thrown. 

2.5. Data Dictionary of the Database 

ColumnName DataType Comment 

sd_priv INTEGER(11)  Primary Key 

name VARCHAR(30)  Name of the permission 

ins_on DATETIME  Timestamp 

ins_by VARCHAR(30)  Inserted By 

Table 1 – sd_priv – Permissions table 

 

ColumnName DataType Comment 

sd_xml INTEGER(11)  Id of the xml document that this property is related to  

property VARCHAR(300)  Property name 

Table 2 – sd_property – XML Document properties table 
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ColumnName DataType Comment 

sd_role INTEGER(11)  Id of the role 

name VARCHAR(30)  Name of the role 

ins_on TIMESTAMP Inserted On Timestamp 

ins_by VARCHAR(30) Inserted By 

upd_on TIMESTAMP  Updated On Timestamp 

upd_by VARCHAR(30)  Updated By 

Table 3 – sd_role – Roles table 


